Nach Neuinstallation Probleme mit der Grafikkarte

Servus!

Ich bemüh euch in letzter Zeit des öfteren, geb ich zu, aber ich hab ein kleines Problemchen.

Nachdem ich nu endlich über eine Studentenversion von Win XP Professional (Service Pack 3) an eine Windows CD gekommen bin, bin ich nun in der Lage, meinen PC neu aufzusetzen. Melodie der Ode an die Freude einfügen Habe ich auch gemacht und meine Festplatte formatiert. Nun logischerweise erstmal Wifi-Center installiert und das Windows Update drüber laufen lassen; wenn ich den nun anschmeisse findet er keine Updates mehr.

Nun hatte ich leider ein Problem: Ich habe ein paar Spiele wieder installiert und beim Start des Spiels (nach gelungener Installation) sagt mir das Spiel, es gebe ein schweres Problem mit Direct X oder der Grafikkarte.

Nun gut, dachte ich mir, das wird wohl am Treiber liegen, laden wir manuell einen neuen runter. Suchen wir doch erstmal den genauen Namen heraus: System -> Gerätemanager. Hmm…kein Reiter “Grafikkarte”. Gut, das liegt mit Sicherheit an der Grafikkarte.

Meine GraKa ist eine ATI Radeon HD 4800 series (ich glaube es ist die 4850). Da ich das Catalyst Center noch nicht wieder installiert habe, hab ich das erstmal versucht jetzt runterzuladen. Der Download klappt (ich finds ja super, dass der PC mir scheinbar auch ohne Grafikkarte ein Bild liefert, er erkennt sie ja angeblich nich…), dann geht es an die Installation:

Wenn ich Sprache und Dateipfad ausgewählt habe stellt er mich vor die Wahl: Installation oder Deinstallation. Der kluge Nutzer wählt natürlich ersteres. Doch leider gibt es ein Problem: Er schließt sich wie in “Hey du, ich schließ mich um gleich dem richtigen Installationscenter Platz zu machen”, verliert jedoch nach “Hey du, ich schließ mich” die Lust daran. Unter Anwendungen ist es logischerweise nicht mehr, der Prozess ist noch vorhanden und arbeitet mit ca. 37k und 2-7% CPU Auslastung, aber es passiert (oberflächlich) nichts und nach ner Weile macht dann auch der Prozess Feierabend.

Hat jemand auch nur den HAUCH einer Ahnung, was ich machen könnte? Ich bin total ratlos ehrlich gesagt…

Also wenn ich alles richtig verstanden habe, versuchst du, das CCC zu installieren, hast aber noch keinen Treiber für deine Karte installiert?
Das solltest du andersherum probieren. Am besten erstmal den Treiber von der CD die bei deiner Graka dabei war installieren, da dürften keine Probleme auftreten. Danach den neusten Radeon-Treiber mit CCC (downloaden und) drüberinstallieren. Wenn du die CD nicht mehr findest oder hast, erstmal nur “Driver only” runterladen, den installiern, dann nochmal das komplette “Paket” mit CCC drüberinstallieren.

Die Installationsroutine für das CCC bringt den display Treiber bereits mit und installiert den auch als erstes.

Mal ein Tipp ins Blaue:
http://support.amd.com/us/kbarticles/Pages/ATICCCInstallFreezes.aspx

Da du ja sämtliche updates bereits gefahren und scheinbar auch schon einiges an Software installiert hast, kann es durchaus sein, dass die dort erwähnte mfc80u.dll aktualisiert wurde.

Hört sich doch eigentlich genau wie mein Problem an…ich werd das morgen definitiv mal ausprobieren, ich bin gerade kaputt und steig da grad nicht mehr ganz durch, aber zunächst mal danke :slight_smile:

Auch CriticalError vielen Dank! Wenn das andere nicht klappt, werd ich das auch nochmal ausprobieren, auch wenn ich das eig schon gemacht hab, aber da wollte er dann wieder was mim Catalyst Center machen und da geschah genau das gleiche und…ich bin müde^^

Am besten erstmal den Treiber von der CD die bei deiner Graka dabei war installieren, da dürften keine Probleme auftreten. Danach den neusten Radeon-Treiber mit CCC (downloaden und) drüberinstallieren.

Das ist Blödsinn, gerade bei ATI Karten machen alte Treiber bei der Installation einer neuen Version nur Probleme.
Ich musste bisher immer den alten Treiber restlos entfernen und dann den neuen installieren um das CCC der neuen Version zum laufen zu bringen!

Benötigt die Installation nich zufällig Microsoft .NET Framework ?

Evtl solltest du dein Windoof erst entsprechend updaten. Außerdem empfehle ich dir mal directX neu zu installieren und DANN erst den CCC.

Versuchs mal

@Bernd das Brot
Also bei mir hat das bisher immer (naja bei meiner aktuellen Karte erst 2mal gemacht) reibungslos funktioniert…
Ich dachte immer, den alten Treiber restlos zu löschen ist nur bei einem Kartenwechsel nötig?

Hm… wird man normalerweise nicht nur vor diese Wahl gestellt, wenn noch alte Treiber installiert sind?
Hastes mal mit “Deinstallation” versucht?
Ich kenn mich mit der ATI Soft net so aus, weil NVIDIA-User, aber für mich klingt das so, als würde das Installationsprogramm abbrechen, um zu versuchen, die Deinstallation der alten Treiber zu starten und sich dabei aufhängen.
Vielleicht vorher mal manuell deinstallieren?

Hört auf mit dem rumgefrickel … :mrgreen:

Beim Aufsetzen eines Rechners musst Du einer bestimmten Logik folgen … und nicht Schritt 3 vor 1 machen.

Primär wichtig: Das OS muss komplett rauf sein. Also …

Wenn keine Treiber-CD mehr dabei ist oder der Rechner schon so alt ist, das die beigelegte CD eh für die Tonne sein dürfte … folgendes Procedere anwenden. (Ich mach sowas fast regelmässig bei Kunden … das Verfahren ist also “reality-proofed” …

1. Hardware identifizieren.
OS- Raufsemmeln und ein Tool wie “Everest” oder “Sandra” laufen lassen. Hardware notieren.

2. Treiber sammeln
Von einem zweiten Rechner aus in’s Netz gehen und die passenden Treiber von der Herstellerseite holen. Ggf. mal das Changelog durchsehen, ob Kompatibilitätsprobleme oder Bugs auftreten und ggf. 'ne ältere oder stabilere Version vorhanden ist.

3. Rechner plätten
Jetzt den Zielrechner komplett formatieren, partitionieren und das OS installieren. Einfache simple Standardinstallation ohne Faxen.

4. Netframework installieren
Viele Treiber oder Diag-Tools brauchen diesen M$-Rotz … also drauflegen.
Ggf. als ersten Treiber den NIC- oder WiFi-Treiber installieren.

5. Updates fahren
Billy-Boy ist ja dafür bekannt, das seine OS immer ziemlich buggy sind und das er Service-Packs und Updates ausstreut wie Oma Lemke Lollis an die Enkel. Also erstmal komplettes Updateprogramm durchlaufen lassen … hierbei aber bestimmte Updates ausklammern. (Generell die automatischen Updates deaktivieren und nur selektiv arbeiten).

6. Rechner rebooten
Spätestens jetzt sollte man den Rechner rebooten. Hierbei aber nicht bloss den “Neustart” machen, sondern die Kiste mal 30sec. auslassen. Bei einem Neustart wird der Speicher nicht komplett stromlos und so können sich noch Fragmente im RAM halten, die ggf. zu Probs führen können.

7. Treiber installieren
Jetzt mal in die Systemsteuerung linsen, ob die Hardware komplett erkannt ist oder wo noch " :?: " rumgammeln. in der Reihenfolge: Chipsatztreiber — Audiotreiber – Grafiktreiber die unter “2.” gesammelten Treiber aufspielen. Auch erkannte Hardware (mit M$-Standardtreibern) kann jetzt mit aktuelleren Treibern upgedatet werden.

Mindestens jetzt nochmal einen kompletten Reboot (mit Abschaltung).

8. nochmal Updates
Da die Updates bei jedem Neustart abgefragt werden (wenn man das nicht unterbunden hat) sollte man jetzt nochmal ein Update fahren … und da werden noch einige kommen. :mrgreen:

9. Spezialtreiber installieren
Wenn man speziell konfektionierte Treiber (z.B. für die Graka) haben will, dann ist jetzt der richtige Punkt. Ich rate von solchen Tools wie “Autoinstall” oder irgendwelchen “…-centern” ab. Diese tools sind meistens von der richtigen Konfiguration der Firewall oder von Malware-Blockern abhängig, da sie - logischerweise - die Konfiguration des Rechners analysieren und übermitteln. Deshalb: eigenständig den Treiber (und DirectX) installieren.

Wer mag, kann vor Punkt “9.” noch ein Fullimage der Platte (z.B. mit “Clonezilla” oder “A.T.I.”) machen, falls ihm dabei das System zerblasen wird. :mrgreen:

10. Spass haben
Jetzt sollte eigentlich alles asta bone laufen und man kann sich an’s “finetuning” machen, also die kleinen Microsoft-Geisterchen wieder in den Keller sperren und unnötige Hintergrund-Tasks unterbinden.

@ Isegrimm:

Womit partionierst du ?
oldskewl fdisk oder nimmst Programme wie PartionMagic etc ?
und dann solltest evtl noch dazu sagen welches Format man formatieren sollte. NTFS oder FAT32 ? (FAT 32 ist z.b. für ne ältere Linuxpartition freundlicher während ntfs für reine Windows Systeme vorzuziehen ist, oder irre ich mich da ?)

ps: wie aktuell ist noch der Parameter (format) /u ?

Watt?

Er hat “Windows Vista Prof” und Windoofs bietet Dir bei der Installation die Möglichkeit des Partitionieren schon im Vorfeld an.

Ich hab nicht von “post install partioning” geredet.

Ansonsten nehme ich cfdisk und mkntfs

Ach igitt…Vista. Sorry hatte ich überlesen.
Trotzdem danke :wink:

edit: ne halt mom…

:smt017

Mein Fehler … stimmt. Er hat XP. :oops:

WAT? Ich hab doch kein Vista O____O Das ist XP verfluchte Kacke :open_mouth:

@Isegrimm: Puh okay, da scheint mir doch glatt ich hab ein bisschen was falsch gemacht. Wenn ich versucht habe, zuerst Direct X zu installieren ohne auch nur an GraKa treiber zu denken, war das wohl etwas falsch, was?

Edit: Partitionieren kann ich doch schon beim Neuaufsetzen…Ich hab zwei Partitionen; C mit 250GB und noch eine mit ca. 50GB. Und einen unpartitionierten Bereich mit 8MB. Formatieren läuft mit NTFS.

Edit: Gut dass ihrs eingesehen habt, und dass mir hier bitte keiner mehr vorwirft, ich würde auch nur an Vista denken :mrgreen:

Jaaa,… is ja gut, Brauner … gaaaanz ruuuuhig … *Zuckerstückchen geb’ und Kopp tätschel.

könnte man so sehen, … DirectX ist nix weiter als 'ne optimierte Sammlung von Grafik- und Audio-Schnittstellen … die sich logischerweise an den Grafik- (und Audiotreiber) bindet. Wenn Du dem System also keinen Grafiktreiber vorweg gibst … woran soll sich DirectX dann anbinden? :mrgreen:

Noch ein Tip von mir. Es gibt bei Omega-Drivers optimierte Grafiktreiber für Gamer. Solltest Du mal mit antesten.

Hühott, Hühott im kreis hüpf Pschrrr…

Okay, war das mit Direct X dann gravierend falsch oder findet er dann sogesehen einfach nichts und macht nix? Heisst das Direct X steht mir im Moment im Weg und blockiert was oder es hat einfach nicht geklappt?
Ich denk, ich werd heute oder am Wochenende ohnehin mal probieren, deine Anleitung zu befolgen und ihn erneut ganz aufzusetzen.

Ist wirklich das Mittel der Wahl. Lies hier noch kurz die Tipps am Ende … da kannst Du 'ne Menge Performance rausholen (und es minimiert den Ärger).

Denk auch mal über ein Imaging (z.B. mit “Clonezilla” nach, wenn Du eine stabile Konfiguration hast. Damit kannst Du über solche Probleme lachen und … bei Viren musst Du Dich auch nicht wirklich mit dem Putzen auseinandersetzen. Einfach das Image zurückbügeln und alles ist cremig.

Wenn Du genug Plattenplatz hast, denk ggf. an ein Dual-Boot-System nach. Ein System zum Zocken und eines zum Arbeiten. Du kannst jedes so zurechtschrauben, wie Du es für den Anwendungszweck brauchst (wer braucht beim zocken Office oder ähnliches ).

Auf jeden Fall sorg für einen zweiten, I-net-fähigen Rechner. So kannst Du parallel recherchieren und ggf. Treiber nachholen. Und …

… nimm Dir Zeit. :mrgreen:

Ich hab hier ohnehin meinen Laptop dabei, von daher ist das mit dem zweiten Rechner kein Thema^^

Zwei OS’ draufklatschen wird bei 320GB Festplattenspeicher etwas antipositiv. Vielen Dank für die Tipps, mal schaun wann ich das noch mach :mrgreen:

antipositiv - Unwort des Jahres ? :mrgreen:

Ne, aber wieso sollte 320 gig nicht ausrecihen für ne 2. Systempartition ? Du musst nicht gleich Spiele und Filme mitspiegeln…nur das jungfräuliche OS + Updates/Treiber und Schnittstellenprogramme wie DirectX und net.Framework. Dafür reichen schon nichmal 5gb.

Übrigens, wenn man eh schon beim Partitionieren ist kann man auch gleich ne eigene kleine Partition (4-5gb) für die Auslagerungsdatei von Windows an letzter Stelle einrichten. Da freut sich Windows und das Defragmentieren geht leichter von der Hand.

Blöde Frage: ich hab wie gesagt 2 Partitionen (eine 244 GB die andere 55GB) und 8 MB unpartitionierten Bereich. Ist der unpartitionierte nu für die Auslagerungsdatei und das ist zu wenig? Ich hab von sowas verschwindend geringe Ahnung…