Chrome-Theme lokal als CRX-Datei abspeichern

Hi,
Ich benutze SRWare Iron und als Erweiterung für den Windows Explorer das Programm Clover, was ihm eine Tab- und Favoritenleiste wie bei Chrome verleiht (sehr praktisch). Um einen einheitlichen Look zu gewährleisten würde ich gerne dieses Theme auch für Clover verwenden, dieser verlangt allerdings eine CRX-Datei. Wenn ich das Theme erneut herunterlade, verschwindet die CRX sobald sie sich von selbst installiert hat :frowning:
Weiss jemand wie ich sie trotzdem auf die Festplatte bekomme?

Hier der Link: Klick

Rechtsklick -> Link speichern Unter …

Fertig ;).

Vielen lieben Dank :slight_smile:
Und wie hast du es hingekriegt? Ist das einfach der direkte Link? Das hab ich nämlich auch schon probiert und es ist nicht gegangen.

Ich hatte auch mal das Problem, dass ich eine CRX Datei laden wollte. Ich hab dann etwas gegoogelt und herausgefunden, dass man einfach folgende Schablone nutzen kann:

http://clients2.google.com/service/update2/crx?response=redirect&x=id%3D[ID]%26uc%26lang%3Den-US&prod=chrome

Da musst du nur [ID] mit der ID der Erweiterung ersetzen. Die kannst du ganz einfach aus der URL ablesen, indem du einfach den letzten Teil des Pfades nimmst, also das was nach dem letzten “/” steht. In deinem Fall war das die URL:

https://chrome.google.com/webstore/detail/marc-ecko/opjonmehjfmkejjifhhknofdnacklmjk

Also hat die Erweiterung die ID:

opjonmehjfmkejjifhhknofdnacklmjk

Und wenn du das jetzt oben in die Schablone einfügst, erhälst du die fertige URL:

http://clients2.google.com/service/update2/crx?response=redirect&x=id%3Dopjonmehjfmkejjifhhknofdnacklmjk%26uc%26lang%3Den-US&prod=chrome

Hört sich vielleicht auf den ersten Blick etwas kompliziert an, ist aber kinderleicht ;).

[QUOTE=STaRDoGGCHaMP;331885]Ich hatte auch mal das Problem, dass ich eine CRX Datei laden wollte. Ich hab dann etwas gegoogelt und herausgefunden, dass man einfach folgende Schablone nutzen kann:

http://clients2.google.com/service/update2/crx?response=redirect&x=id%3D[ID]%26uc%26lang%3Den-US&prod=chrome

[/quote]

Hi,
ich habe diesen Link versucht, er funktioniert nicht!

Es kommt immer diese Fehlermeldung:[B] error-invalidAppId Error 404[/B]

Was jetzt?

Du musst das [ID] durch die ID des addons ersetzen :slight_smile:

[QUOTE=Rynam;372893]Du musst das [ID] durch die ID des addons ersetzen :)[/QUOTE]

Hab ich gemacht, geht trotzdem nicht!
Kommt immer wieder dieselbe Meldung.

Ich habe es jetzt mit 3 Browsern probiert: Google Chrome / SRWare Iron und IE
Kommt immer wieder dasselbe heraus, also 3 Browser können sich nicht irren.

Neue Schablone

https://clients2.google.com/service/update2/crx?response=redirect&prodversion=31.0.1609.0&x=id%3D[ID]%26uc

Wieder [ID] durch die extension id ersetzen.

[QUOTE=STaRDoGGCHaMP;372979]Neue Schablone

https://clients2.google.com/service/update2/crx?response=redirect&prodversion=31.0.1609.0&x=id%3D[ID]%26uc

Wieder [ID] durch die extension id ersetzen.[/QUOTE]

Danke, aber es geht nicht.
Ich geb´s auf, das ist doch alles Mist.

Wenn mal was wirklich funktionierendes rauskommt werd ich´s noch mal versuchen.

Gib mal den link zu der extension.

[QUOTE=STaRDoGGCHaMP;373028]Gib mal den link zu der extension.[/QUOTE]

PS: ist aber nicht nur damit ein Problem sondern mit allen Erweiterungen

Also bei mir funktioniert es: Klick (Rechtsklick -> Link speichern unter…)

[QUOTE=STaRDoGGCHaMP;373037]Also bei mir funktioniert es: Klick (Rechtsklick -> Link speichern unter…)[/QUOTE]

Hallo,
also ich habe heute noch mal einen anderen Browser ausprobiert, es geht nicht!

Es kommt immer das hier:
[B]error-invalidAppId

Error 404[/B]

Mittlerweile ist das der 4. Browser mit dem es nicht funktioniert, bisher waren es:
**Internet Explorer
**Google Chrome
**SRWare Iron
**Baidu Spark Browser

Es muß doch irgendeine Ursache haben.
Als ich noch das Alte Betriebssystem (XP) hatte funktionierte das mit diesem Link.
Jetzt habe ich auf meinem etwas älteren Laptop (Fujitsu Siemens LifeBook E8020) das Windows ThinPC (32bit).
Das ist ein von Microsoft ziemlich abgespecktes Windows 7, das extra auch für Ältere Hardware gemacht wurde.

Kann mir aber nicht vorstellen das es daran liegen sollte, dann hätte ich ich ja dauernd Probleme mit irgendwelchen
Webseiten.
Aber das es ausgerechnet[U] nur mit diesem Link [/U]nicht funktioniert versteh ich nicht, es ist so als würden sich hier alle
Browser dagegen Sperren.
Habe im Internet noch dies gefunden : http://chrome-extension-downloader.com/
Aber damit geht es auch nicht bei mir, da kommt dann immer das hier:
[B]Not Found

The requested URL /7c55d35751824fa76909d3b485853c00/https://chrome.google.com/webstore/detail/instant-dictionary/fcjmbgoamdpbndikpbaoeoidaabejfmd.crx was not found on this server.[/B]

Irgendeine vorstellung was das Problem sein könnte?

/7c55d35751824fa76909d3b485853c00/https://chrome.google.com/webstore/detail/instant-dictionary/fcjmbgoamdpbndikpbaoeoidaabejfmd.crx

Das ist ja auch keine URL, nimm mal das Hash-Gedöhns davor weg

[-]/7c55d35751824fa76909d3b485853c00/[/-]https://chrome.google.com/webstore/detail/instant-dictionary/fcjmbgoamdpbndikpbaoeoidaabejfmd.crx

Edit: Gut, das geht auch so nicht :smiley:

StarDoggs Link geht bei mir aber auch (Chrome Linux)

[QUOTE=Domino;373203]Hallo,
also ich habe heute noch mal einen anderen Browser ausprobiert, es geht nicht!

Es kommt immer das hier:
[B]error-invalidAppId

Error 404[/B][/QUOTE]
Also wenn du wirklich den Link aus meinem Post angeklickt hast und da der Error gekommen ist, dann ist das schon äußerst merkwürdig. Spontan kann ich da aus der Ferne auch keine wirkliche Ursachenforschung betreiben. Es können eigentlich nur äußere Einflüsse sein. Vielleicht mal den Link über einen Proxy versuchen oder mal auf einem anderen Betriebssystem testen in einer virtuellen Maschine oder so. Oder vielleicht das ganze mal aus einem anderen Netzwerk versuchen? Keine Ahnung, ist nur ins Blaue geraten, aber das hört sich sehr merkwürdig an was du da erzählst. Bei mir funktioniert der Link jedenfalls, sowohl im Chrome als auch im Firefox.